What iOS should I have on my phone so I can use Xero TaxTouch?

You would need to have iOS 9 or later to use Xero TaxTouch on your iphone.

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk